Draw Distance issue and NPC Names/Gathering points disappearing then reappearing

LordlyBeast Profile Options #1

2

I've tried turning down my settings, turning them up, fiddling with draw distances and any number of things I could think of. I can't seem to fix this, or is this something that's working as intended?

I've found these other posts talking about it, but no one explains how they fixed it, or if they did. Someone said this isn't supposed to be how it looks normally. So other users are experiencing it as well.

https://www.reddit.com/r/TeraOnline/comments/2mfnv0/does_anyone_else_have_this_issue_where_the_name/

http://www.reddit.com/r/TeraOnline/comments/2tm3lw/is_there_any_way_to_increase_the_distance_names/

For whatever reason I can see NPC names and gathering points from a huge distance, but as I close on them they disappear then reappear when I get VERY close to them. Seems like they are loading a second time or something as I close in on them, and gathering points will not show up at all, unless I'm literally targeting them once I get close.

I have fully updated all my drivers. So I know nothing is outdated.

If anyone knows anything about this, please share. Even if it's just a setting that can be toggled or changed, or what setting needs messed with to change it. It's pretty annoying so far, but nothing I can't live with for now.
SingleBear Profile Options #2

1

Basically what Counterpoint says:

counterpoint on 08/03/2015, 09:55 PM - view
It's just how the UI works, and it is annoying. There's a sort of "distance mode" and a "close-up mode", and the transition between the two isn't seamless. So as you're approaching a target, you will often see the "distance" label, then it'll disappear, and re-appear as the "close-up" label once you're closer. There's no known fix -- even reinstalling, or drivers, or UI reset, or whatever. Everyone I've seen streaming TERA has the same issue. As far as I can tell, it's the game coding.


Bluehole has continued to work in optimizations to help players that experience lag due to other nearby objects/players. One method is to limit the amount of things loaded at one time. So the game is doing what Counterpoint refers to; when you get close to an object, the game decides if it should be loaded or not. This should be seamless and as mentioned, for some it is. But not for all.

I will grab the video submitted by Tsukasakun and send to Bluehole.
TsukasaKun Profile Options #3

2

2
Friendly
Emonas Lvl.65
Tempest Reach (PVE)
Castanic Sorcerer
I have the same issue. It started with the patch that added Reapers if I remember right. Still haven't figured out why and just sorta gave up trying. It was only ever a problem during the old Nexus since nodes were always so crowded that mob/NPC models/textures would take comparatively ages to load. Had to find mobs solely by the red dots on the radar 'cause the names would disappear and they'd be invisible while their model loaded..

Here's an old video I did showing the issue: https://www.youtube.com/watch?v=3lsjU4j3VFE
Edited by: TsukasaKun over 2 years ago - Reason: Added link
LordlyBeast Profile Options #4

2

I still haven't figured anything out for a fix. I've tried different resolutions, as well as different draw distances, and it's all the same. Currently I'm forced to raise my gathering by using the radar to actually find the gathering nodes, or just visually spotting them, obviously without any label.

Any idea if running the repair tool would help? EDIT: Ran both tools from the launcher. Came back with my machine being more then enough to run Tera, and the repair tool picked up nothing.

I also went in and switched all my files off from read only, thinking that might help. All it did was make it so windowed full-screen runs properly, for w/e reason. Before it would take up like 2/3rds of the screen and jam everything into a corner in a weird resolution. So at least it fixed that.

Also, I've seen others streams/youtubes of the game from various dates and stages, and they DO NOT suffer from this problem. Some of them even have similar set ups or worse than what I have.

So it boils down to this.

Will the repair tool fix it? Or am I looking at re-downloading the whole game again? (A second re-install did nothing to help).

Is it possibly a driver issue (Running a nvidia 560ti and it's updated to the latest drivers), and if so where can I download a more stable or previous driver version to run with the game?

Is it a Direct X issue? Is there a way I can set it to Direct X 9 instead of 11 through a .ini file or something?

Is it a UI error? Is there a way to reset the UI or display with in game commands or through altering a file?

Is there a possible corrupt, misplaced or damaged file, if so what is it, and what do I have to do to replace/repair it?

That's all I can think of off the top of my head that I haven't just been able to troubleshoot sitting here.

So far all the info for this problem that I could find, is literally sitting right in this thread.
Edited by: LordlyBeast over 2 years ago - Reason: Info
counterpoint Profile Options #5

2

It's just how the UI works, and it is annoying. There's a sort of "distance mode" and a "close-up mode", and the transition between the two isn't seamless. So as you're approaching a target, you will often see the "distance" label, then it'll disappear, and re-appear as the "close-up" label once you're closer. There's no known fix -- even reinstalling, or drivers, or UI reset, or whatever. Everyone I've seen streaming TERA has the same issue. As far as I can tell, it's the game coding.
Edited by: counterpoint over 2 years ago
LordlyBeast Profile Options #6

2

Thanks for the response guys.

I hope this ends up helping someone else as well. To me it was just jarring and strange, since I could have swore last time I played it was a smooth transition, but it looks like alot of people are in the same boat.

I'm assuming the transition is probably smoother with faster net, at least that's my guess, and why I never noticed it before, but I can sure tell that when I get closer to things they are loading a second time.

If anyone comes up with a UI program (something such as windower for FFXI as an example) or some other mod or a .ini tweak to adjust it, is it fine to use/do that? Or is that something we wouldn't be allowed to use/do?