-Game Bug- UI issue with keybinds (e.g. Ctrl-Z)

scootle Profile Options #1

2

1
Favorable
Rarrgh Lvl.65
Tempest Reach (PVE)
Castanic Warrior
I noticed that this bug remains active... if I map "Z" to a spell or hotbar command, the Ctrl-Z default/system keybind for hiding the UI ceases to function. It was previously detailed in an old thread way back in 2012 here:

https://tera-forums.enmasse.com/forums/general-discussion/topics/UI-BugsFeedback-Consolidated-List
{KEYBINDING} - Issues or suggestions regarding binding controls.

[BUGS]

3. Stacked UI keybinds conflict with game keybinds Keybinds for opening menus, changing shortcut trays, hiding UI etc. causes issues with game keybinds (when a modifier key is used to make a separate bind to same key).
This is a difficult one to explain, so here's an example:
If you bind Z to a spell, and Ctrl-Z to Hide UI, when you hit Ctrl-Z, you will cast the spell.


Any fixes or solutions? I noticed that I simply do not have the option to hide the UI via Ctrl-Z any longer on the characters that have Z mapped to a spell/hotbar... even if I unmap it. The option to re-bind Hide UI to a different key combination appears to be missing in the shortcuts menu.

Thank you!
Edited by: scootle almost 3 years ago - Reason: formatting
SingleBear Profile Options #2

3

We sent a bug for this issue to the developer in early 2012. They closed the issue without a fix and informed us to have the affected user re-keybind hiding the UI to something other than Ctrl-Z.

Sorry. I realize this doesn't fix your problem.
scootle Profile Options #3

2

1
Favorable
Rarrgh Lvl.65
Tempest Reach (PVE)
Castanic Warrior
Any potential fixes? I noticed on the affected characters I simply cannot turn the UI on/off at this point for screenshots other than going to the costume/gear preview screen...

My understanding is that keybinds are stored server-side, correct?
csubakka Profile Options #4

1

3
Trusted
Kusunoki Lvl.65
Celestial Hills - Roleplay (PVE)
Elin Mystic
I have healing immersion bound to Z on my priest. My easy fix for this problem is ot switch to an empty bar quick before pressing Ctrl-Z
scootle Profile Options #5

2

1
Favorable
Rarrgh Lvl.65
Tempest Reach (PVE)
Castanic Warrior
SingleBear on 06/08/2015, 03:34 PM - view
We sent a bug for this issue to the developer in early 2012. They closed the issue without a fix and informed us to have the affected user re-keybind hiding the UI to something other than Ctrl-Z.

Sorry. I realize this doesn't fix your problem.


That's a bummer... but on a revisit to the Shortcuts UI, I was able to rebind my "Hide UI" function to Ctrl-U instead, which seems to have somewhat "fixed" the issue for now. Not sure why I missed that option previously when I looked for it, but that's on me.

Thanks!