Priest Energy Stars (Bugged?)

Nurk Profile Options #1

2

I've seen a few threads on this but they were outdated. So when using energy stars like a good priest I've noticed that sometimes it just doesn't work at all but the cooldown applies. The target is very much alive when I cast it and even in a party with my friend it will sometimes buff me but not them when they are standing right beside me or the opposite. I asked around and a lot of priest told me that yeah it's just bugged to hell and depends if the gods smile on you that moment. So if this is really a bug can we pretty please get a fix or is it a lag issue or something totally different? Please help :p
SingleBear Profile Options #2

1

Have you noticed any consistency with this issue? Does it tend to fail for you no matter when and where or do you notice more failure in dungeons and BGs?
Nurk Profile Options #3

2

SingleBear on 05/28/2015, 05:39 PM - view
Have you noticed any consistency with this issue? Does it tend to fail for you no matter when and where or do you notice more failure in dungeons and BGs?


It seems rather random to be honest but after a few hours of play last night I would say every 3 out of 10 times it seems to fail. It fails pretty much at any place but I notice it more in dungeon groups where I'm constantly trying to make sure it's on everyone. I thought maybe it was something I was doing but I went BAM hunting with a friend of mine to test it out a bit more and it was still about 3 out of 10. I even had them check their buffs and stats in case it was like a graphic glitch but they said they had no buff and their stats were the same as before. Of course we checked the stats again when the buff actually showed and it did infact reflect on the stats page. I hope we can get something sorted with it like if it fails maybe not incure the CD or something? In 5mans it's a pretty big dps loss in the long run and makes most priest that know how to use it look silly for seeming to not use it.

Edit: I did notice however if you say cast energy stars and then immediately go for a healing skill is when it tends to cancel itself. Course that might just be me casting too fast but it shows my character doing the stars animation and still sometimes applies the buff to just her or just a single person so idk but I thought it was worth mentioning.
Edited by: Nurk almost 3 years ago - Reason: more info
Krantom Profile Options #4

2

0
Neutral
Juicy.Yuuji Lvl.65
Mount Tyrannas (PVP65)
Human Lancer
I think I've had this happen to me as well, but I found the cause was casting another spell during a small casting window after launching energy stars and before it hits. If this does turn out to be the problem it's an easy solution, just wait a little bit extra. Energy stars is a bit too valuable with too long of a cooldown to risk wasting.
Nurk Profile Options #5

2

Krantom on 05/29/2015, 08:02 PM - view
I think I've had this happen to me as well, but I found the cause was casting another spell during a small casting window after launching energy stars and before it hits. If this does turn out to be the problem it's an easy solution, just wait a little bit extra. Energy stars is a bit too valuable with too long of a cooldown to risk wasting.


While I respect what you're saying here, I went back in game to try my luck and while yes it was less frequent (about 2 out of 10) it still was happening of the buff only applying to me when a party member was right beside more and once or twice just failing entirely. While testing your theory though I did notice if I head into the lock on heal skill directly after stars is when it almost always fails. So perhaps I'm casting it too quickly but as I said it did still have issues. Plus quite a few people I spoke to ingame seemed to have similar issues on the subject so I'm not sure. Either way thank you for the suggestions, I have started to stand still more for the cast but it's disheartening at times when it still fails even then.